is it just me or is it the site.....

i got a couple things i am wondering about.....

1) when i post a NEW topic such as this one.....i get a big error message at top. after i post it the first time, but it doesn't show up when i view the post later.
2) i have a set signature in my account setup.....it shows up fine in replies to other posts but doesn't show up when i make a new topic of my own.

------------------------------------------
Greg
Http://www.myspace.com/kybassmaniac
Http://www.upthecreekstudios.com

wheat's picture

Greg, I'll check the logs

Greg,

I'll check the logs for that error message. If you can copy/paste it into a comment, it might be helpful.

I'll add the signatures on new posts issue to the issues list.

Thanks for the bug reports!

Wheat

bassplaying.com

here is the error....

user warning: Unknown column 'n.body' in 'where clause' query: SELECT 1 FROM node n INNER JOIN node_revisions r ON r.nid = n.nid INNER JOIN akismet_spam_marks s ON s.content_type = 'node' AND s.content_id = n.nid WHERE (s.hostname = '216.78.205.40' OR n.body = 'i got a couple things i am wondering about.....\r\n\r\n1) when i post a NEW topic such as this one.....i get a big error message at top. after i post it the first time, but it doesn\'t show up when i view the post later.\r\n2) i have a set signature in my account setup.....it shows up fine in replies to other posts but doesn\'t show up when i make a new topic of my own. \r\n\r\n' OR s.mail = 'grhodus@bellsouth.net') in /home/.orlenda/jamesnotjim/bassplaying.com/includes/database.mysql.inc on line 121.

also another thing i noticed and wondered if there is a fix for....when a post has more than one page of replies.....when you click new in the recent posts listing to go to newest one it only takes you to the first page (ie. the hello topic has 140 replies and if you click new it take you to first page instead of the third page which is now the newest entires.)

not complaining just trying to do what i can to help.:-)

------------------------------------------
Greg
Http://www.myspace.com/kybassmaniac
Http://www.upthecreekstudios.com

*and it harm none,do what thou will*

------------------------------------------
Greg
http://www.youtube.com/user/BroknDreamsBand
Http://www.facebook.com/brokendreamsband
http://www.reverbnation.com/brokendreamsband
*and it harm none,do what thou will*

wheat's picture

I appreciate the bug

I appreciate the bug reports. That's clearly an SQL error and It looks like the Akismet module is involved. I might try disabling that module (as it's really designed, I think, for sites that allow comments w/o registration. Like blogs and such). I haven't had this error yet. Anyone else seen it?

I'll disable Akismet and post back. After that, please try posting a new thread and let me know if the problem persists.

The new posts in long threads issue is a persistent one with Drupal. The only workaround is to turn off thread pagination (i.e. list every thread as one big, long page). The advantage of that is that it's easier to find new comments on long threads (I've thought of archiving the "I"m new" thread and starting a new one for the same reason). The downside is long threads take more time to load.

Would you guys like me to turn off pagination and let you try it for a few days to see if it's an improvement? It might be fore us, since most threads here don't get to be very long.

Wheat

bassplaying.com

wheat's picture

I bumped the pagination

I bumped the pagination setting up to 200 per page. That should help all current threads. See if that's better or worse.

Wheat

bassplaying.com

works for me

of course i have 6mb dsl so loading pages is not an issue with me.....hope it doesn't make the load too long for those on dialup..... it shouldn't tho since the pages don't have much graphics and those are the worst demon to load

------------------------------------------
Greg
Http://www.myspace.com/kybassmaniac
Http://www.upthecreekstudios.com

*and it harm none,do what thou will*

------------------------------------------
Greg
http://www.youtube.com/user/BroknDreamsBand
Http://www.facebook.com/brokendreamsband
http://www.reverbnation.com/brokendreamsband
*and it harm none,do what thou will*

wheat's picture

Akismet, off

Okay, GR. Give it a go and see if you get the same error. I've temporarily disabled the Akismet module.

Wheat

bassplaying.com